Jump to content

Issues with join LPU11


Jats
 Share

Recommended Posts

Hey LPL,

 

since yesterday I try to buy my first annual LPU membership plus the LPU11 CD. Unfortunately the registration doesn't work for me. I add the shit to the cart and click 'Checkout' but on the next page I get an error, even before I click the button register. I type in my name, email and everything else, but it seems to me as the captcha doesn't load. It looks like that:

 

Posted Image

 

 

First I thought, the problem was that I'm from Germany, but I also tried it by using a US proxy and a friend of mine can't join LPU neither. I also tried to contact the ground(ctrl) support and checked out their help page but even after updating Firefox or using Internet Explorer it doesn't work.

 

My question is very simple now .. how the fuck can I fix this shit ? adaminator1 said that he already twittered to adam, because he had this error too but it still doesn't work for me. Anyways, I would appreciate it very much if someone could help me out with that.

Edited by Jats
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...